Before you can update any properties associated with an object or layer, you will need to select it. The process for selecting objects is pretty intuitive and likely something you're familiar with, especially if you've used other design tools.

In this article, we'll cover all the basics for selecting objects, as well as some lesser known tips and tricks:

  1. Select an Individual Layer.
  2. Select Multiple Layers.
  3. Selected Nested Objects orLayers (Deep Select).
  4. Use Smart Selections.

Tip! To quickly select all objects within a Canvas, you can use the Select All function under the Edit menu. Or, use the Keyboard Shortcut [⌘] + [A] (Mac) or [Ctrl} + [A] (Windows).

Select an Individual Object

There are a number of ways that you can select an object:

From the Canvas

  1. Click on the object in the Canvas.
  2. A blue bounding box will appear around the edge of the object, with a handle in each corner.

If your objects are nested within another object, group, or layer, then you can double-click on the object to select a layer one level down. You can then repeat the double-click until you get to the correct selection.

Or, you can use the Deep Select function by holding down the [⌘] (Mac) or [Ctrl] (Windows) key while clicking on an object in the canvas, to directly select a nested object (Learn more about Deep Select).

From the Layers Panel

You can also select a layer from the Layers Panel.

  1. Layers are arranged in the Layers Panel by Page, and are named based on the type of object they are.Tip! Naming your layers as you go, with logical and easily identifiable names, will help you to find them in the Layers Panel. Check out our Renaming Layers in Bulk article.
  2. If there are any Frames or Groups on the page, objects within those Groups or Frames will be nested within that Frame or Group in the Layers Panel.
  3. You can then use the arrow next to the Frame or Group, to view any nested objects.
  4. If you hover over the layer in the panel, a blue box will highlight that layer's location on the Canvas.
  5. Click on the object to select it.

Select Multiple Objects

You can also select more than one object or layer at a time. This is great when you want to update a property across multiple layers, resize layers in bulk, move a collection of objects; or create a Group, Frame, or Component from the selection.

From the Canvas

  1. Select an object in the Canvas.
  2. Once an object is selected, hold down the [Shift] key and click on another object.
  3. This will allow you to select as many objects as you like.

You can also select objects using the Marquee tool:

  1. Click and hold on a empty part of the canvas.
  2. Drag the cursor across any objects you'd like to select.
  3. A blue box will indicate which objects are included in the selection.
  4. To select nested layers with the Marquee, hold down [⌘] (Mac) or [Ctrl] (Windows) and drag the marquee across any objects you'd like to include.

From the Layers panel

This requires a slightly different approach.

  1. Select a layer in the Layers Panel.
  2. To select all layers between two layers, hold down the [Shift] key and select another layer:
  3. To select multiple layers individually, hold down the [⌘] (Mac) or [Ctrl] (Windows) key and select another layer:

Tip! You can also use the Edit menu to select multiple objects based on their properties. Once a layer is selected, you can choose to also Select All other layers that have the same: Properties, Fill, Stroke, Effect, Text Properties, Font, or other Instance.

Select Nested Objects

If you're working on a more complex design, you likely have a bunch of objects nested within other groups or frames.

When you click on an object that is part of a group or frame, the whole frame/group will be selected by default.

We have a couple of different ways to select nested objects. We refer to this as Select Layer.

1.Hold down the [⌘] (Mac) or [Ctrl] (Windows) or key while clicking to Select Layer.

2. For even more accuracy, you can hold down  [⌘] (Mac) or [Ctrl] (Windows) and Right-Click on an object to open the Select Layer mini menu

This allows you to see the full list of layers under the cursor. The layer icons and names will be shown in the same order as the Layers Panel, but do not indicate hierarchy.  

Tip! Layers within Components and Instances will be displayed with a purple icon.

3. You can also get to the Select Layer menu by Right-clicking on an object and choosing Select layer.

Working with Locked and Hidden Layers

If a layer is hidden, then it will not be shown in the Select Layer menu. The layer must be unhidden before it can be selected in this menu.

If an object or layer is locked, then it can't be selected via the normal left-click selection process; however, it can be selected via the Select Layer process. Locked layers are included in the Select Layer menu, with a padlock icon to indicate they are locked.

Smart Selection

Smart Selection allows you to quickly and easily adjust the spacing and arrangement of objects on the canvas. This is perfect for making adjustments to a design for an email inbox interface, or a social media news feed/timeline.

Learn more about Smart Selection.

Did this answer your question?